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Tomography and data analysis: A Recap 

X-ray tomography (XRT) is based on the acquisition of a high number of radioscopic images of 

the same sample under different viewing angles. The final reconstruction provides a 3D map of 

the local value of the attenuation coefficient of small elements of matter at a scale down to the 

resolution of the technique. Each of these elements, discretizing the material is called a voxel 

by extension of the term pixel used in 2D imaging. Each voxel is associated to a grey level in the 

reconstruction being proportional to the local attenuation level. 

Once the stack of raw grey level has been produced, extracting quantitative parameters from 

3D images requires appropriate image processing, segmentation and analysis :  

- Image processing is generally applied to “improve” the image. It mainly involves grey level 

modification (equalization, normalization, brightness and contrast adjustment, etc.) and 

filtering (to remove noise or to subtract background) in the spatial or frequency domains. 

- Segmentation is the procedure by which the grey level images are transformed into a much 

simpler information in which each point in the image is affected a color depending on the phase 

it belongs to. This can be made by simply thresholding the grey level images, but much more 

advanced procedures are sometimes necessary (adaptive thresholding, trainable segmentation 

based on machine learning algorithms, …). 

- Image analysis is devoted to the determination of meaningful measures of the constituent 

phases and their geometries, for example to quantify their number, fraction, size and 

distribution. 

There are two classes of measurements : global or feature-specific. Global measurements apply 

to the entire structure and do not attempt to distinguish the details of how the components 

are organized (ex: the volume fraction).  

Feature-specific measurements attempt to describe the frequency distributions of particle size 

and shape. In order to compute parameters for each object individually, it is necessary to group 

all the pixels belonging to a same object (in this case, a void) and to give each of them the same 

label (i.e the same grey level, allowing to identify voxels belonging to the same void). This 

operation is called labelling. The resulting labelled images are then used to measure individual 

morphological parameters for each object (voids, particles, …). 

 

 

 

 

 

 

 



Objective: 

The objective of this exercise is to provide a first introduction to XRT applied to study the 

damage evolution within metal structures.  

The following points will be covered: 

- Learn to open and navigate 3D XRT scans (i.e. stack of images) 

- Perform basic segmentation and morphological operations  

- Generate 3D visualizations 

- Compare 2D and 3D analysis regarding: (i) strain measurements (i.e. not directly 

related to damage), (ii) void volume fraction (global parameter), (iii) density and (iv) 

size of voids (feature-specific measurements).  

This exercise only serves as a concise introduction and a collection of useful references can be 

found in chapter 8 of the MEALOR II book.  

Data set and software:  

The data sets used for this exercise session are related to the paper "On the origin of the 

anisotropic damage of X100 line pipe steel, Part I: in-situ synchrotron tomography experiments" 

published by Madi et al. in Integrating Materials and Manufacturing Innovation. We will only 

use a few scans, but the complete dataset is available here: 

https://zenodo.org/record/3528199#.ZHb2OoTP02w.  

In this study, the damage evolution of a grade X100 line pipe steel were investigated using in-

situ synchrotron-radiation computed tomography (SRCT) of notched round bars (see Fig. 1, 

right). Three scans (scan 01, scan 06 and scan 13, see Fig. 1 left) will be used (folder SCAN INIT), 

they have been obtained on a specimens loaded along the rolling (L) direction.  

 

Figure 1. Left: Load-displacement curve of the in situ tensile test, with points corresponding to scan 01, 06 and 13. Right: 
Geometry of the notched axisymmetric sample, with the red box indicating the typical field of view and the corresponding X-

ray projection (for scan 01). 

   

https://zenodo.org/record/3528199#.ZHb2OoTP02w


The first scan (scan 01) has been obtained in the early stage of elastic regime, and it will be 

used as the initial state (i.e. the minor εel is neglected). Scan 06 and scan 13 were obtained after 

significant void nucleation/growth and at the onset of the final coalescence stage that triggers 

catastrophic failure of the specimen, respectively.  

1. Open and explore 3D data: 

A straightforward method to have a first quick look at your data is by using orthogonal views, 

accessed via Image › Stacks › Orthogonal Views. Windows containing the two planes will dock 

alongside the original stack, with the intersection of the yellow lines on the stack indicating the 

point in the stack that is being analyzed. The planes will update automatically by adjusting the 

lines on any of the three windows. 

Note that the X, Y, Z and grey level of the voxel identified with your 

mouse is indicated in the ImageJ/Fiji window.  

 

 

 

 

 

 

What can you conclude regarding the plastic deformation of these samples ?   

Useful tip: Note that when working with 3D data, i.e. stack of 2D images, several 3D operations 

can be found under via Image › Stacks.  

Useful tip: ImageJ/Fiji > File > Import > TIFF Virtual Stack  

A virtual stack is a way to work with multiple images as if they were frames of a stack, without 

actually loading all the images into memory simultaneously. This is particularly useful when 

dealing with large datasets that might exceed available memory. Instead of loading all images 

into RAM, the virtual stack loads images on-demand as you navigate through them. However, 

note that some operations that require access to all images in the stack simultaneously might 

not be available or might behave differently when working with a virtual stack. 

2. Segmentation and 3D Views of Damage Evolution (in ImageJ/Fiji): 

Visualization:  

Open Scan 01 and do Plugin>3D viewer, select the volume of interest, select display>Volume 

and Color>None in the opened window.  

In the ImageJ/Fiji 3D Viewer, a noteworthy feature is that the “black” phase of the image is 

rendered as transparent. However, the background is not necessarily perfectly black (i.e. gray 

level of 0 in 8bit) and the 3D view is thus not very interesting.   



Useful Tip: By adjusting the transparency settings (Edit > Change Transparency in 3D viewer), 

you can potentially achieve a clearer representation of your sample's internal structure. This 

can be particularly advantageous when exploring raw or unprocessed data, allowing you to 

manipulate transparency levels to visualize certain aspects of the image without performing 

segmentation. 

Segmentation: The main thresholding command in ImageJ/Fiji is Image > Adjust > Threshold.  

It will open a threshold dialog that allows you to identify pixels above a threshold, below a 

threshold, or falling between two thresholds. These options are controlled using a combination 

of the threshold sliders and the Dark background checkbox. There is also a drop-down menu 

allowing you to select from a list of automated thresholding methods. 

A. Segmentation of external surfaces: 

Set the threshold value to encompass the entire 

specimen, with a particular emphasis on accurately 

defining the external edge of the sample. Prioritize 

achieving a well-defined outer boundary. It's not 

necessary to be concerned about internal porosities or 

background noise at this stage, as these aspects will 

undergo post-processing in the subsequent steps. The 

result generates a binary stack, i.e. black and white image 

(0 and 255 grey level in 8 bit).  

 

 

A straightforward method to eliminate internal porosities involves employing the "Fill holes" 

operation: Process > Binary > Fill Holes. Note that several basic morphological operations are 

also available, e.g. erode/dilate, which are commonly used for 3D data analysis.  

A practical way to keep only the edges is to use the Particle Analyzer in ImageJ/Fiji and analyze 

each cross-section as a large particle. First, go to Analyze > Set Measurements and select Area 

and Stack Position. These results will be used later to compute the local strain for the 

corresponding cross-section.  

Then, go to Analyze > Analyze Particles. A simple trick to ensure that 

only the large cross-section is analyzed (and not possible 

background noise which was selected during the Thresholding) is to 

set an appropriate minimum area of particles to analyze (see Figure).   

In the Show dropdown menu, select Bare Outlines, which will 

generate a stack of image with only the boundary of each cross-

section.  



Save the generated stack containing these external boundaries (File > Save as > Tiff…), it will be 

used for 3D visualization of the external surface of the specimen.  

Furthermore, save the results generated (i.e. Area/slice analysis). Note that the number of 

cross-sections should correspond to the number of slices (e.g. 641 for Scan 01). If you have 

extra/missing cross-sections, adjust the minimum cross-section in the previous step.   

Useful Tip: Sometimes, you perform an operation in ImageJ/Fiji, and realize that it was 

performed on the white/black pixels, while it should be the opposite. In such case, you can do 

Edit>Undo to undo the last operation and then Edit>Invert in order to invert white and black. 

This is also useful to make sure that the background is black before performing a 3D rendering.  

B. Segmentation of internal porosities: 

Open the original scan and this time set the threshold value to 

encompass the internal porosities. Again, it’s not necessary to be 

concerned about the background being selected at this stage.  

A practical way to keep only the internal porosities is to use again 

the Particle Analyzer in ImageJ/Fiji.  

In this case, a simple trick to ensure that only internal porosities 

are analyzed (and not the background) could be to set an 

appropriate maximum area of particles. Another way is to select 

the Exclude On Edges option of the particle analyzer (which will 

exclude all objects touching the edge of the volume, i.e. the 

background in this case).   

Furthermore, select Masks in the Show dropdown menu before running the analysis (which will 

open a new stack with the internal cavities). Again, save the generated stack and the results.  

C. Visualization  

Open the saved volume (ex: internal porosities) and open the 3d viewer: Plugins > 3D Viewer. 

Don’t forget that the background should be black for 3D rendering.  

Select display as volume and select a color for the porosities. A 3D view of cavities will open. 

Then go to File > Open in the volume viewer window and select the second volume (i.e. the 

boundaries of the sample) and select a color.  

Then, adjust the transparency of these external boundaries: Edit > Select and select the external 

volume. Then go to Edit > Change Transparency and adjust as needed.  

Congratulation, you just made your first 3D rendering of an XRT data.   



 

 

Note that some ring-shaped artifacts can be observed. They are inherent to the tomography 

technique and could be removed by post-processing (extensive literature available on the 

topic). During the analysis in the next sections, we will limit ourselves to exclude the slices 

containing these rings.  

Importantly, you can add a scalebar using View > Edit Scalebar.  Alternatively, you can annotate 

the image with a specific dimension directly on the 3D rendering, such as the diameter of the 

central cross-section. The second approach aids in providing a clear reference for the spatial 

scale, enhancing the interpretability of your rendered data. 

D. 3D analysis: 

Finally, the last operation to be performed with ImageJ/Fiji is to analyze the internal porosities 

directly in 3D (as opposed to the previous steps, generating 2D results as a function of the Z 

position for each slice). In order to compute the size and the position for each cavity, it is 

necessary to group all the pixels belonging to a void (i.e. labelling operation, see introduction). 

However, Fiji provide a useful tool “3D Objects Counter” which directly encompass the labelling 

step with the evaluation of parameters (much similar to what has been done in 2D with the 

Particles Analyzer).   

Note however that 3D analysis becomes quickly very computationally expensive and it would 

probably not possible to analyze the full scans on your laptop. Sub-volumes of previous volumes 

containing the segmented internal porosities are provided in the folder Segmentation > Internal 

Porosity  (again selected in such a way that they correspond to the same volume in 3D for each 

deformation step).  

Perform the 3D analysis by doing: Analyze > 3D-OC Set Measurements  and select volume and 

centroid.  Then do Analyze > 3D Objects Counter and save the results for each scan.  

The results generated with ImageJ/Fiji on each scan within this section will be used for further 

analysis in the next sections. If you lost too much time for performing the analysis on all  scans, 

these results are available in the SEGMENTATION folder, containing internal porosities and 

external surfaces (stacks and results).  



3. Compare Average and Local Strain (in Matlab, Python or what you like) 

You might have noticed that the number of slice in each scan was different. This is due to the 

fact that a first "cropping" operation was performed in order to ensure that the same volume 

was observed in each scan. In other words, the first and last slice of each scan follow the same 

point physical point on the surface of the specimen. Since we are deforming the specimen, 

while the voxel size (also corresponding to the slice thickness) is constant, the number of slices 

is increasing. This cropping operation could be done manually by following features in the 

volume when possible (note that markers are sometimes glued on the surface of the sample). 

Sometimes, it is also required to correct for rigid body motion of the sample between scans, 

and extensive literature is available for automatizing this correction called "rigid registration" 

(i.e. the process of aligning or matching different images to a common reference frame).   

 

After cropping, the volume height can thus be associated with the displacement that would be 

measured by an extensometer (with the field of view dimension along the loading direction 

corresponding to the gauge length).  On the other hand, the ratio between the initial area and 

the current area represents an average value of the true strain within a given cross-section: εloc 

= ln(A0/A).     

Compare the average strain over the whole field of view (i.e. what you would measure with an 

extensometer) with the evolution of the local strain. Compare and contrast the insights gained 

from average and local strain measurements. 

4. Compute the evolution of the local void volume fraction  

One of the most frequently used global measurement is the volume fraction, usually noted as 

FV . The subscript is used to indicate a dimensionless ratio of volume per unit volume. 

In this section, we will evaluate how accurately the area fraction (FA), which can be obtained 

for each slice (Z position) allows to evaluate the volume fraction FV. This is interesting because 

FA corresponds to what would have been obtained from conventional 2D methods (e.g. optical 

microscopy after polishing).  

Furthermore, studying the evolution of FA from 2D slices of the tomographic volume is also 

interesting in the case of in situ tensile tests, especially after the onset of necking. Indeed, the 

evolution of porosity is significantly influenced by the local strain and fV is thus strongly linked 

to the position along the sample.  

Using the results of previous sections, quantify the evolution of void area fraction FA as a 

function of the Z position (i.e. for each slice).  



How can you compute the void volume fraction Fv from the evolution of FA ? 

What can you conclude about the heterogeneity of damage within the sample ?  

 

5. Analyze the evolution of the density of voids: 

It is important to note that there are some fundamental parameters and three-dimensional 

structure that cannot be determined from two dimensional images.  

For instance, it is not possible to look at a two dimensional image of a plane section and 

determine whether the phase of interest consists of discrete voids, or whether they are 

connected (i.e. forming a micro-crack after void coalescence).  

Using the results of previous sections, quantify the evolution of the density of voids (i.e. NA 

number of voids per area unit in 2D or NV number of voids per volume unit in 3D).  

What can you conclude about their evolutions ?   

 

6. Analyze the evolution of the void size distribution and basic tracking: 

Finally, compare the evolution of the average size obtained in 2D/3D/  

Furthermore, it is sometimes useful to look at the evolution of parameters, following each void 

from one scan to the other (void tracking). A simplify approach to void tracking has traditionally 

been to assume that the largest Ntrack (usually 20) remains the same. Compute the size 

evolution of these Ntrack porosities, what can you conclude ?  

 

 


